EarthData WNRO issue

In case you were hit by the EarthData WNRO issue yesterday, we have implemented a fix at the software level.

1 Like

Thank you Andres & Co for the patch. You saved us a lot of traveling and money replacing digitizers.

I had to delete my seedlink buffer for those stations and restart seedlink when I applied the patch.

The slinktool output was as follows:
ZA HVD BHE D 2099/12/13 11:39:37.9450 - 2019/08/07 11:59:37.7950
ZA HVD BHN D 2099/12/13 11:39:32.7450 - 2019/08/07 11:59:50.9450
ZA HVD BHZ D 2099/12/13 11:39:46.0450 - 2019/08/07 11:59:53.0950
ZA HVD HHE D 2099/12/13 11:39:48.3100 - 2019/08/07 11:59:57.1800
ZA HVD HHN D 2099/12/13 11:39:48.2900 - 2019/08/07 11:59:56.0800
ZA HVD HHZ D 2099/12/13 11:39:45.7800 - 2019/08/07 11:59:53.6900
ZA HVD LOG L 2099/12/13 11:00:00.0000 - 2019/08/07 11:00:00.0000

Which caused scrrtv not to show real-time data nor was scautopick picking on any of these traces. Scolv picker could also not load the data from seedlink buffer. It was fine when using arclink so one could manually pick easy enough.

Anyway, I scratched my head for a while, so thought I might save someone else the trouble.


I reckon if our seedink buffer was only a few hours in size it would remedy itself rather quickly…

I can confirm Gerhard’s reports:

  • Our 4 affected stations produced data of 1963.
  • The second version of patched serial_plugin installed on station’s SeedLink boxes fixed the problem.
  • No on-site inspection and/or hardware changes was needed.
  • Many Thanks to Andres and team!
  • slarchive worked well with 1963 data, so meanwhile I corrected archived miniSEED files by constant time shift.
  • Our archive (nearly) didn’t lost any data.
  • scolv & scrttv & real time processing weren’t able to access actual (correct timed) data from lokal SeedLink buffer, as long 1963 data were contained.
  • Waiting for outaging of 1963 data didn’t help.
  • Removing complete SeedLink buffer of affected stations fixed the problems of scolv & scrttv & real time processing.
  • At the end: all issues were solved - Thanks again!